Recent Activities

  • Conny

    Posted the thread Login "url not found".
    Thread
    Hi,

    after a long time I tried to login into my Backend with "/admin"
    I've got the error message "

    Not Found

    The requested URL /admin was not found on this server.




    What's going wrong ?
  • Mach7

    Posted the thread Portfolio not paginating.
    Thread
    Hello guys!

    I've set 12 projects per page in Portfolio Settings, yet my portfolio displays all projects in one single page. What am I missing?

    Thanks for the help!

    EDIT: there are no js/ajax errors on the console. The output is clean.
  • konga77

    Replied to the thread Problem with sitemaps.
    Post
    apt , did you solve your issue? Here, on an 1&1-Server (Ionos), I've got exactly the same issue:

    Click on "GENERATE"
    -> Popup appears "Sitemap-generation is in progress.." After a second, another, empty popup appears.
    -> sitemap.xml file appears in…
  • Tobbe

    Replied to the thread Blog - URL are deactivated.
    Post
    I assume you created your own custom url and used a not-supported feature. For example, using the id in your own slug has a bug: https://github.com/pagekit/pagekit/issues/926

    Workaround until this is fixed: Change the url of your blog posts to not…
  • cloudlgs12

    Post
    May be it was related to plugin issue.. Check if all the plugins are up to date.
  • dorfworker

    Post
    Hi, i read all Comments about Advanced Blog but I must ask this stupid Question. I have the normal Blog Extension with 71 Blog Post and Comments. Is there any Way to import all the Posts in the Advanced Blog Extension. I think to import every Post…
  • EssEff

    Posted the thread Blog - URL are deactivated.
    Thread
    All my Blogposts have the url disabled. Why and what can I do about it?

  • Fosphatic Duke

    Replied to the thread No route found for "GET /".
    Post
    That is excatly what i have described you, how to run pagekit locally without any xamp or what ever environment. Only php is needed...
  • Tobbe

    Post
    Hi Uuumpf,

    yes, app is provided as variable to the template, so this should be possible. As an alternative you can also register a callback for the view.init event and provide the information as global directly there. Then you can access it also using…
  • Tobbe

    Replied to the thread Problem with login to admin panel.
    Post
    Hi Designer,

    if I see it correctly, then it should be in the system config table in a row with column "name" having value xadmin.

    Best regards,
    Tobbe
  • Asfalcom

    Replied to the thread No route found for "GET /".
    Post
    I don't really understand what you're saying.

    Pagekit runs normally but I don't know how to open projects locally that I've downloaded from hosting
  • Fosphatic Duke

    Replied to the thread No route found for "GET /".
    Post
    When you want to use pagekit locally just use the build in webserver.

    Unzip pagekit

    Download and unpack php7. 2 if you are on Mac or Linux u good to go if on windows you need to add the php path to the environment path variable.

    Then just open a…
  • Designer

    Thread
    Hi everyone!
    Installed XAdmin but forgot the path address in the admin panel.
    Could you tell me please where can be his watch ? In what directory and in what file ?
  • spmash

    Thread
    So when i try to install ANY extension from marketplace I will get the mistake.
    (Code, 2 lines)

    How i can close the mistake????
    SETTING VALUE
    Pagekit Version 1.0.16
    Web Server Apache/2.2.29 (Gentoo) mod_dp/0.99.7 PHP/7.3.1
    User Agent
  • Asfalcom

    Replied to the thread No route found for "GET /".
    Post
    Dear, I have another project that is operational; Download the entire project folder to my pc and save it in the path C:\xampp\htdocs.

    Start the Apache and MySql service in XAMPP
    Then I open the browser and place the path http://localhost/fdp/ where in…
  • Fosphatic Duke

    Replied to the thread No route found for "GET /".
    Post
    Hi there,

    don't use xamp! Use the build in webserver with pagekit to check it out on a local machine. In ge eral the error message says that a pdo driver is missing. Enabling it in your php.ini could help probably to get rid of this message.

    Regards
  • Asfalcom

    Posted the thread No route found for "GET /".
    Thread

    (Code, 27 lines)


  • Uuumpf

    Post
    Maybe app->node()->slug is the way to go? It seems like one has access to $app inside template.php.
  • Uuumpf

    Thread
    Hi,

    I'm trying to modify a template to dynamically add a html-class to a position-div in template.php.

    The class name should contain the id or slug of the current page.

    For example:
    When page "home" is rendered, class "main-home" should be added,
  • humantex

    Replied to the thread Problem with sitemaps.
    Post
    I assume that if the file is generated, at least the directory it's generating to doesn't seem to have a permissions issue. The only other thing that stands out is the Vue message (in #3) about the formExclusions "setting a non-existent path".

    Are…