Pitfall "Your requirements could not be resolved to an installable set of packages" solved

  • Hello,


    developing my last extension I mentioned that I was able to install my packages uploading the zip directly was possible without any problems. Installing it using the marketplace failed with


    Quote

    Table Of Contents 1.0.0 wird installiert

    Loading composer repositories with package information

    Updating dependencies

    Your requirements could not be resolved to an installable set of packages.



    This strange behavior is a result of the dependency-management of the Pagekit-marketplace itself. The Pagekit-team is going to solve the problem - as a workaround you can add the dependencies of your requirements directly to your composer.json.

    In my case I had to change the requirements from


    Code
    1. "require": { "caseyamcl/toc": "^1.0.0",}


    to


    Code
    1. "require": { "php": ">=5.4", "caseyamcl/toc": "^1.0.0", "masterminds/html5": "~2.1", "cocur/slugify": "~1.0", "knplabs/knp-menu": "~2.0"}


    Now the extension is installable via marketplace aswell.


    MalteScharenberg told me that it should be possible to change it back to


    Code
    1. "require": { "caseyamcl/toc": "^1.0.0",}


    in the next update as the marketplace does not forget packages that are in the index once.