Need help with applying "grid".

  • Hello there.


    First to say, I'm not expirienced in web-programming at all (started learning a week ago, lol) and basically trying to learn something just for personal education. Got some basic html courses and practice a bit in making a landing page with UIkit. Then I found Pagekit.


    So I installed it according official guide, look at some themes, widgets and so on, everything worked kinda fine, but then I tried to make a grid. Ta-dam, it wasn't working. Code was taken by UIkit default "grid" parameter:

    Result shown in 1st attachment.

    I tried to do same thind in some other themes and result was the same. Then I suggested that Pagekit themes aren't using uikit.min.css and uikit.min.js by default. Surprisingly (for me) I found that I was right.

    So I tried to import this 2 files into themes, adding them to css and js folders respectively and writing their path in template.php, and it seems like css is importing succesfully, but js isn't. Then I found this thread and made the same (and rollback changes made in template.php). I've tried both variants (adding autocomplete.js and grid.js.), but problem remains.
    Things I've also tried:

    1. Making my own theme according this guide and add grid on it. Result was the same, more of that, I failed at adding smooth scroll component.

    2. Adding various assets (both together and separately): both variants of uikit.js, grid.min.js, both grid.js variants from /app/assets/uikit/js/core. Zero response as well (2nd attachment for example).

    It feels like I am missing some very basic thing about importing uikit's javascript, but still am completely lost.:(

    Thanks in advance for any replies!

  • Well which te. plate are you using the default theme one? If yes then of course it's not working the code you have provided as it's uikit v3, but the original theme one is based on UIKit v2 framework.


    There is still the documentation available for v2 uikit so if you try the code examples from there, then you should have no issues. The Syntax have changed slightly that's why u experiencing those problems.


    Regards,


    Fossy