Error updating

  • Hi everyone,


    I'm currently using pagekit 1.0.13. When i got to the admin panel it says there is an update to 1.0.15.


    I want to update but the automatic feature doesn't work. When i click "update" nothing happens.


    I get no error message and In the server logs i don't see any error or problem. It's just that nothing happens.


    Maybe error on permissions?


    I don't really want to upgrade manually ;) so anyone on the forum have any idea on what to do or what to check to get it to work?


    Thanks ;)

  • SAB

    Approved the thread.
  • Same here. When I update from 1.014 to 1.015, the progress bar shows 100% and the message "Preparing update... Your database is up to date" is displayed.


    However, obviously the installation has not been successful: "Pagekit 1.0.15 is available. Update now!"


    The error console does not show anything. What exactly do I have to do to identify the reason for the failure?

    I had no problems in the past.


    Thanks in advance.

  • Hey guys, please try to upgrade from ssh console in that case. Just login into telnet oder ssh session and navigate to the pagekit root folder. Then try following command:


    Code
    1. php pagekit self-update

    I'm guessing that you had the bad luck that the upgrade script took slightly longer then usually, or your provider has for security reasonst pretty short script execution times enabled. This should work from the console after all and on some hosting server you have to use php-cli instead of php in your shell session.