Hidemail

  • Hi Roman,

    I have installed your Hidemail extension via the marketplace.

    In order to try it, I have opened a test page I had already created, and I added on a new line my email address.

    But nothing happened : when viewing the page in my browser I still have my address readable.

    I did nothing else than intalling via the marketplace. And it seems that I have no parameters to change.

    Have you an idea ?

    Thanks.


    JF

  • That's just what it should do. If you disable JS in your browser, as the crawlers do, because they do not actually render the page, you will see that the address is no longer visible.


    Have a look at the screenshots :)

  • I illustrated this with this little screencast - before reloading the page I turned JS in my browser on and off. Having JS disabled the address can not be displayed (as we wished) and having it enabled it can be displayed:



  • Today I released version 1.0.1 that fixes problems with bixie's formmaker extension.


    You can also define, on which pages the extension should be included (default: all) if you want to exclude a specific page.


    Code
    1. ## 1.0.1
    2. - ADD: Adds possibility to choose, where the plugin should be activated
    3. - ADD: Added French translation (thanks to f1evm)
    4. - ADD: Added German translation
    5. - FIX: Solves a problem with extensions that are posting content to embedded views
  • I just published version 1.0.2, which comes with a little bug fix and one improvement.


    Code
    1. ## 1.0.2
    2. - FIX: Fixes a bug that did not correctly handle mail addresses that occur more than once per page
    3. - FIX: Improved performance