Attempt to update from dashboard, leads to 404 page missing

  • I try to update Pagekit for the first time, through the admin dashboard at /pagekit/index.php/admin/dashboard. However, the update link leads me to: /pagekit/admin/system/update, which doesn't exist. How can I fix this?

  • SPQRInc

    Approved the thread.
  • I try to update Pagekit for the first time, through the admin dashboard at /pagekit/index.php/admin/dashboard. However, the update link leads me to: /pagekit/admin/system/update, which doesn't exist. How can I fix this?

    Well Index.php should not be visible in the url in optimal circumstances. Do you tried to have URL rewrite on on your server?


    In some cases it is necessary to install a plugin from pagekit extensions store for URL rewrite but it should not cause this problem. Do you tried to enable the debug mode and debug bar? I think then you will see a more precise explanation what is going wrong.

  • If this fails you could give a try to update from ssh console of your server just type in the root folder of your pagekit installation php pagekit


    It should bring up the possible parameters and one of them should be something like selfupgrade so if it is available try then php pagekit selfupgrade I never seen this method failing before at least.

  • I didn't know that was a thing, I'll try that. Enforce Rewrite URL... "Use this extension only if your website also works without the index.php in urls!" Is this the right thing for my case? (This is self-hosted on my raspberry pi, by the way)

  • Well it doesn't matter if it is a raspy mate, just the right setup for the Webserver. If I may guess I would say you use nginx right?


    Nginx is a bit tricky to setup for pagekit but it is possible. I'm using nginx at my workplace to run pagekit as intranet entry point for each workstation. We'll the last update I did not tried to setup as I have changed some files from the backend but after my vacations I could try to upgrade it and with importing my changes after all. It is slightly more work that's why I did not upgrade the instance there already.


    edit:


    well probably if you use nginx the package for it is slightly out of date, but if it a distribution based on Debian or Ubuntu then you could get newer version directly from nginx official sources. There are some good tutorials how to manage it. The thing is nging isn't always compiled with all the modules available.


    Plus you can do still the php pagekit selfupgrade from ssh connection to raspy to upgrade pagekit.

  • Okay apache is a Webserver too but probably as well outdated version. The thing is Debian is cool but very very conservative when it comes to packages. Did you had any warnings due prerequisites test due pagekit Installation?


    Nginx is a Webserver / reverse proxy that perform very nice on weak hardware especially. But you should be good with pagekit and apache too as pagekit don't need too much resources!

  • https://pagekit.com/docs/getti…rted/server-configuration


    here is the official guide from yootheme, but as you are you own hosting provider in this case you will need to check it yourself if mod rewrite is enabled and those allow override through .htaccess


    If the pagekit installation isn't extracted in the root folder of your apache installation then you need to edit .htaccess file especially because you need to edit the rewritebase this is normally always / but if you put your pagekit files into a subfolder like /var/www/html/pagekit then you need to change the value to /pagekit and delete the # in front of the line with rewritebase.

  • Just tested it, that didn't work. I did just find out that my version of Apache is 4 years old (2.4.10), that may have something to do with it... although the linked guide does say 2.2+ is supported, so maybe not. The rewrite module is enabled, just checked again. Maybe I should just start from scratch?


    Also, since installing that plugin, the dashboard is now less functional.


    https://i.imgur.com/mvavDik.png


    EDIT: Looks like I've gotta fix the htaccess file like you said, trying that.

  • Deleted. I put it on /pagekit/ because I wasn't ready to overwrite my existing site, so I guess I do need to fix the config now so that /admin works. Needing to include "index.php" shows that something is configured incorrectly, yeah? Though, at least that update notification was the only broken link, all the other navigation works there.

  • I need to get some sleep now as it's almost 1 in the night here and shift is calling in 5 hours. Catch you tommorow!


    By the way I have an arm dev board at home that has an old Debian image and I was able to find a way to run nextcloud 11 on it with ngnix so don't give up it is possible with raspberry too! Paget need way less.

  • I'll just get a newer version of Apache installed, hopefully that'll take care of the issue. Thanks for your help!


    EDIT: Nope, that didn't do it. Is there something wrong in my .htaccess file? http://paste.ubuntu.com/p/tDs8gJq8Wk/


    Also while I normally use SSH to the static local IP of the Pi, to actually access the website from elsewhere I do use a domain:


    http://www.cwhymedia.com/


    though Pagekit isn't live on root yet.